<- Home Page *Search  



Reply to topic Post new topic
AlumCJ, JohnnyJ, Trailrig or.....
 
 PostPosted: Tue Apr 06, 2010 3:51 pm 
User avatar
strangler is hoser's shrink

Posts: 4679

Offline
..... Anyone else that knows anything about GM electronics:

97 454, All stock OBD II stuff.
It took me a couple trys to get the dist phased correctly to have the cam position sensor reading 0deg while the Ign adv reads 25deg on the scan tool (per the factory manual), but I'm there now.
Engine sounds healthy in open loop and Ign adv stays in the 20's, but as soon as it switched to closed loop the timing remains at 25 until I load the engine and then I loose 10+ deg of timing and it runs like shit.
What tells the computer to control the timing? It RIPS at 25+ deg, but with any load I'm in the low teens and its sick. Manually advancing the dist does nothing for the Ign timing, only moves my cam sensor from 0deg. HELP.

_________________
Currently fearing a Rubiconish pile of parts......


Top
   
 
 
 PostPosted: Wed Apr 07, 2010 1:03 pm 

Posts: 1313

Offline
Pretty much everything can f up spark.

No DTCs, right? Any emissions stuff deleted? Like evap, egr, etc? I'm guessing you can look at data?

My first thing I look at are the basic sensors to make sure they have good data. (MAP, MAF, TPS, IAT, Baro, ECT). Look for one of those signals to get flaky or not move when you get into it.

Then look for knock activity & retard, CMP retard (cam sensor). I'd look for if the IAC position is moving along the desired IAC position. Look if it's trying to add EVAP and how much EGR there is.

Make sure the O2s are switching like they should, too.


Top
   
 
 
 PostPosted: Mon Apr 19, 2010 7:42 am 
User avatar
strangler is hoser's shrink

Posts: 4679

Offline
Its funny how these things always seem to work out.....
Suddenly, driveability and optimum performance are really no longer a concern. I hate my truck.

_________________
Currently fearing a Rubiconish pile of parts......


Top
   
 
 
 PostPosted: Wed Apr 21, 2010 8:49 am 

Posts: 1313

Offline
If you psycho girlfriend ever comes back, here's some info.

I talked with someone here at work about your issue. His first thought is that knock is pulling out your spark, next would be that MAF is way off.

Here's something to check:

Originally Posted by chris demartini on pirate:
>> What is the correct position for a MAF? I assume these are all LSX engines?

> According to John, the tuner, the plug needs to be up. That was the first thing he said when opening my hood.


Top
   
 
 
 PostPosted: Wed Apr 21, 2010 4:17 pm 

Posts: 2949

Offline
Put the stock cam back in it......i know you hate me. :flipoff:

_________________
HOGGIN' "N" BOGGIN'


Top
   
 
Display posts from previous:  Sort by  

[ 5 posts ]
Reply to topic Post new topic


Who is online

Jump to:  

Users browsing this forum: No registered users and 1 guest



cron
Powered by phpBB © 2000, 2002, 2005, 2007 phpBB Group